Ana içeriğe geç

Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

745 Soru Tümünü görüntüle

Cannot access boot utilities - greyed out EFI Boot - SOLVED!

OK, so I have a 2009 2.53Ghz MBP 5.5 from 2009.

I was all working fine with a dosdude Catalina patch until I decided to put a bigger SSD into it and to try to reinstall fresh. I erased the original SSD with the patched Catalina (A mistake for sure) and now All I get is a white screen and eventually a question mark folder. ALL boot recovery options are unavailable, nothing happens when I try to get any utilities such as Terminal or disk utility for example, and the EFI boot is greyed out. It only gives me an option to reinstall Catalina but if I click to install I get a no entry sign. I have reset PRAM and SMC numerous times but the same result persist. It cannot be the SATA cable (Swapped that over 2x) as the HDD can be heard spinning and is indeed recognized in the image attached below (Funny enough a SSD isn't recognized), I tried putting an SSD with Catalina already installed but that won't boot (Question folder). My only guess it the EFI has been corrupted or modified by the dosdude patcher, so HOW can I re-flash the EFI from the EFI Update for 2009 MBP file downloaded from Apple? This one has really got me! I don't have or can't seem to find what OS this originally came stock with) and more so a way to get it on USB to make a bootable (But my guess the same question folder will appear when tried).

Any help would be brill.

Block Image

Update (02/21/24)

BRAINSTORM: Downloaded again the dosdude Patcher for Catalina.

Created a bootable patched Catalina USB

Plugged in the new SSD internally & the USB externally as you do.....

Booted with Option key and the EFI boot was functional and installation was a success!

Set up with exactly the same user name and password.... Bingo.

Conclusion.... Indeed the EFI was tweaked and cannot recognize any changes to hardware as I initially thought, pity I didn't do this before hand, I killed 3 days trying everything 10x.... Never give up :)

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

5 Yorum:

Oh, the cable now has some electrical tape protection on the top and bottom side of the case where it could make contact.... no change.

tarafından

I have also tried formatting to APFS and Journaled - no chang.

Installing Catalina via another Macbook - No change.

Using an SSD with an Installed Cataliana externally - No option to boot from it.

tarafından

@livfe - Hey! I love working with EFI systems. I am glad to hear that you figured out what the problem was.

Now, if you are interested, there is a way to use dosdude1's patcher alongside OpenCore. I have played with the two of them, and I have found out that OpenCore is way more stable and secure. If you wanted, I would suggest you try installing OpenCore onto your Mac's EFI partition, and boot from OpenCore. You still need to root patch with the dosdude1 patcher.

Just a suggestion, it is not required. I would just personally use OpenCore over any other patcher.

tarafından

@jadonlyon Hi, thanks for the info, IF there was a way that I could start again and use just open core then I would try that, it was a flip of a coin, dosdudes or open core... in hindsight open core would probably have been the better choice. I got it working again thats the main thing, next time I will use open core on another MBP.

tarafından

@livfe - Of course! And, yes. As long as you got it working, that’s all the counts!

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:

Who’s SSD did you use? Most today are SATA III (6.0 Gbps) which is too fast for this older SATA II (3.0 Gbps) based system. Some SSDs have auto sense technology most don’t!

You’ll need to review the given drives specs to discover if it’s compatible with older SATA II systems.

Bu yanıt yardımcı oldu mu?

Puan 0

3 Yorum:

Just enable TRIM and all is fine, I used an ADATA SU650 in this 2009 model.

tarafından

@livfe - This is a fixed speed SATA III drive and will create problems with sizable reads and writes as the systems buffers will run out. The only SATA I use in these older SATA II systems is Samsung drives as they offer Auto sense technology! Just compare the spec sheets note the difference.

tarafından

@danj OK Samsung it will be replaced once one comes along... pointless to put my spare 870 EVO in it though... I will remember to check this, thanks gor the heads up!

tarafından

Yorum Ekle

Yanıtını ekle

livfe sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 5

Her zaman: 61