Ana içeriğe geç

Early 2011 Model: A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor

783 Soru Tümünü görüntüle

Using it without battery. Questions.

So, this week I just got one of these, for free, came without it's battery (that became a spicy pillow) and without it's original charger (that became e-waste and was recycled (I don't have any more details on this)).

Question number one, about using it without a battery.

Do I risk damaging it further or anything else by just using it without it's battery? I can't really afford to buy a replacement at this moment.

I managed to buy a really good (not apple branded) 85w charger and it boots, I'm able to install High Sierra (there's waterfox that still lets me browse the internet, and other stuff) also there OCLP I can mess around. I run a terminal command someone said that lets me see of the CPU is throttling and surprisingly it's not (despite ppl saying it would), well, at least I think it's not, because it says 100% in all marks on the terminal.

Also, another question is about Real Time Clock. I noticed that it keeps messing the time and date every time I unplug it.

It laid sitting in it's previous owners stash for several years without it's battery, do I need to replace an RTC battery? (I'm expert on PC, I don't have a clue on how Macs Work, so for me all devices that have an RTC needs a coin cell battery). So do I need such thing? Because I'm also planning to get it an SSD, 8GB of RAM (%#*@ 1333mhz. I have 4 1600mhz sticks laying on my stash but seems I won't be able to use them because of 2nd gen Intel, not sure though, didn't test) so when gather all parts, I'll be disassembling it to clean, repaste, install new ram, SSD, and if needed, the RTC battery.

Thanks everyone!

Update (04/27/24)

Block Image

Would this help @danj ?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
16 Yorum

@liondeolive3180 - Over riding SMC is not smart! You also face the risk of memory & file corruption as the system was not designed to be used in this format. Between the MagSafe connection not being stable and the charger now able to supply the full power some actions require.

tarafından

Well I still don't understand that thing you mentioned about the threads, and I don't really know if it's throttling the system at all.

But the charger is 85w.

The system as is, from what I read is designed to drain up to 65w. So I don't really think it's underpowered at all.

I had to use open core to bring this device to Bigsur at least because otherwise it's basically a paperweight, and it had this option, was the only thing that wasn't default activated.

tarafından

@liondeolive3180 - if you where not overriding SMC then the issue I was talking about would be an issue. As you hadn’t spoken about which OS or how the default OS would be limited by SMC CPU Safe Mode being enabled.

tarafından

Now I'm using BigSur and I have enabled the mod. It's performance seems the same, so another hint that it wasn't throttling before.

tarafından

@liondeolive3180 - Sure that makes sense! As once set you need to flush the SMC settings. Again, you’re running the system in a way it was not designed to do for use.

tarafından

11 tane daha yorum göster

Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

The issue is SMC needs the thermal & voltage sensor inputs from the battery without them SMC goes into CPU Safe Mode which ramps up the fans and lowers the CPU’s clocking. So you do need a battery sorry 😢

As for the clock & date, without power the clock dies often just going to the default value or if there was still a bit of power in the logic board it might hold for a minute or two.

If we compare to a desktop which offers a button battery to hold the settings and power the clock the MacBook laptops leverage their main battery so without it you won’t have a means to power the clock when the AC power is disconnected.

Bu yanıt yardımcı oldu mu?

Puan 1

9 Yorum:

Oh so it doesn't have an extra battery for the RTC, it relies on the main battery for this.

Good to know.

As for the CPU power I am still not convinced it's not giving it's full power.

How can I further check this?

I took the information about the pmset -g thermlog command here:

https://apple.stackexchange.com/question...

tarafından

@liondeolive3180 - Go into Activity Monitor and look at kernal_task process what is it showing?

tarafından

@danj it's looking like this:

https://prnt.sc/hoyQ4Y86eJZ3

tarafından

@liondeolive3180 - Yes that’s the issue as your threads are being blocked. If you connect the display back the value will drop.

tarafından

4 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

lion.lorena sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 8

Son 30 gün: 129

Her zaman: 129