The eMac was an all-in-one G4-based mac designed for the education market. It was the last mac to use a CRT display, and was sold at a low price to schools, and other institutions.

56 Soru Tümünü görüntüle

Replaced HDD, USB doesn't work.

eMac 1.42

Hey all,

My eMac 1.42GHZ was starting to show its age so I decided to upgrade the hard drive and the optical drive.

The teardown / upgrade went ok - I fix laptops but this was my first eMac. When I turned it on after the upgrade, I reassuringly hear the Apple sound and the screen changes to what you would get when an os isn't installed and I can hear both of the drives, but USB doesn't work.

To be more specific, the ports are getting power (Plugged in a bus powered drive) but the keyboard doesn't work - I try to eject the drive and nothing happens, same when I tried a pram reset.

I've tried:

The keyboard on another system - it works fine.

Multiple USB ports.

External drive in usb ports - the drive powers up fine.

Reseating the IDE & power connectors for the optical drive - I can hear the drive power on so I don't think it’s a power issue.

Different IDE cable.

While I was moving the machine the cover that flips down when the optical drive is ejected broke off. Whilst I would like to fix this at some point, at the moment this is a minor concern.

I'm hoping someone who has done a few of these eMacs has some idea about something that I've forgotten to plug in; I've had a good look inside for things that I might have missed and there’s nothing obvious, but then again things like this are only obvious once you've found them.

Any pointers at all would be great.

Cheers.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Interesting problem. The first thing that comes to mind is an ID conflict. I'm not sure if the drives are on the same bus. Try replacing the hard drive with the old one to help isolate the problem. Also did you reset the RAM or change the RAM: eMac RAM Replacement

Bu yanıt yardımcı oldu mu?

Puan 3
Yorum Ekle

Yanıtını ekle

Ben sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 1

Her zaman: 740