Ana içeriğe geç

Repair guides and support for cars, trucks, and SUVs manufactured by GMC.

232 Soru Tümünü görüntüle

Oil Pressure Low Stop Engine

My car is 2010 GMC Acadia I see warning light oil pressure light low stop engine so I check oil level and it seems good and heat not increase also

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3

Yorumlar:

I cannot answer this, but I was googling this because it just happened to me pulling out of the grocery store parking lot! I pulled into another parking spot because it freaked me out. I turned off the engine, then I checked my oil life, which it said 23%. I proceeded to drive back to work (a few miles) and the warning did not come on again.

Wondering if you got any resolution to your issue or if it was just a fluke.

tarafından

I'm having the same issue! I took it to have it checked out and they recommend replacing the sensor. I plan on having that replaced. I REALLY hope that's all it is. :(

tarafından

Anyone have any afterthought on this?

tarafından

I have the same problem. ive been researching a lot about it. For now, all you can do is add Lucas Oil high mileage to it, it will help a lot for temporary until you can afford some parts.

You would have to replace the Oil Pressure Switch, (its on youtube), that will help also, but it doesnt mean it completely solve the problem, and if it doesnt, then you would have to flush out with kerso. it might be clogged, but the kerso can unclog it

heres the youtube link specifically our problem with oil pressure switch.

https://www.youtube.com/watch?v=k0LG_L5A...

very hopeful that ive been somewhat helpful, but im not an mechanic... i am still saving up money before i start fixing my suv following the link ive sent.

best of luck!

tarafından

I just changed my oil pressure sensor and got outta garage .... in 2 mins i had to bring back up to the garage as the engine started making wierd noise and car is vibrating .... all i did was changed the oil pressure sensor cause the indication in my car was kinda bugging me...i drive a GMC Yukon 2011 . I really dont know whats the issue

tarafından

7 tane daha yorum göster

Yorum Ekle

7 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Naif, Heather M , It very well could be a bad oil pressure sending unit/sensor, but better to be safe then sorry and have it checked out right away. If you hear any noises from engine knocking/ticking or if engine is not performing as usual discontinue starting/driving vehicle as there could be a major problem internally of engine. If driveable have the vehicle scanned for trouble codes to see if a failing oil pressure sensor is the issue and have it replaced. Some of the auto parts suppliers offer free code reading like Pepboys, Nappa, Advanced auto parts,etc and some of the guys are very knowledgeable and may have seen the issue often and put you on the right track.

If it is not the oil pressure sensor it could be a more serious problem like a failing oil pump, plugged/ pick up tube fell off, oil filter plugged, etc etc., a good technician will put a manual oil pressure gage on the engine to verify low oil pressure and then have to diagnose why. Good luck. I hope this helped you out, if so let me know by pressing the helpful button.

Bu yanıt yardımcı oldu mu?

Puan 5

Yorumlar:

I just had this happen, but it was making noise also. I pulled over, turned the car off, checked my oil, restarted my car, nothing. Drove away, about 1/2 mile did it again, pulled over, turned the car off, called mechanic, drove there, nothing. I just got the oil changed also

tarafından

Mine is saying low oil stop car I took to have oil changed today, but they were full so I was going home then take it back Monday, but I was almost home it started making a nicking sound then started losing combustion I think is what it's called it didn't want to pull and acted lime it wanted to die I don't think I was going to make it up my up slanted drive way can this be the oil needing changed again I keep it changed everytime it's say it has low oil

tarafından

big dog wwe If you only change the oil when it says low oil your not changing it often enough and youve probably ruined the motor . Start a new question and include the make and model of car and how many miles you go between oil changes

tarafından

Yorum Ekle

I was having the same issue in my 2013 Acadia. Took it to the dealership and I have to replace the oil pump. Very expensive! But it has to be done. When they replace the oil pump they have to redo the timing and everything so if you are having any issues I would take it in to a dealership that knows the vehicle and have them check. I was getting the low oil pressure turn off engine message even after oil change. There wasn't a code to run since it would happen whenever.

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

How many miles did you have on it?

I am having the same problem; 2010 acadia; about 175K miles.

tarafından

Yorum Ekle

Hi @ gail.wadley,

You may have a faulty oil pump.

Here's a link that may help.

Either that or get a mechanic to check it out.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

I have it in an 08. Drive 10 miles, stop and it goes on at low rpms. Put it in neutral and rev above 1000 rpm and it turns off. Right now rpms control it. For all I know a failing oil pump doesn't circulate oil at low rpms?

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

It turns out that replacing the oil pressure sensor fixed the problem. That sensor interface started leaking and made the problem obvious. I would add that the difficulty repairing that thing is reason enough to avoid GM.

tarafından

did you have a code regarding the sensor? Mine is doing the same thing but there are no codes stored.

tarafından

Yorum Ekle

Camshaft sensor accuater the GMC ACADIA has 4 of them one for each cam so you half to see what code its reading out to know which one it is!! Mine is doing same thing guy told me it was timing chain & I need a new timing kit supposed to have something to do with oil pump

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

I had a low oil pressure issue and shuddering. I would be driving, I would start to hear engine noise, idiot lights and warnings would start going off. I would pull over, turn the engine off and restart, it would be fine. I have a friend who is a mechanic and brought over his $4000 code scanner. He saw the low oil pressure faults but didn't see a cause. He wiped the codes and I haven't had an issue with low oil pressure since. I do have a shuddering though, feels like the transmission but now I'm thinking maybe it is the timing chain. To avoid the shudder, I have accelerate very slowly keeping the RPMs right around 1000 or accelerate quickly, keeping the RPMs between 2500-3000, once I'm past 40MPH I have no issues. Could a timing chain or Cam sensor cause this?

tarafından

I have the same issue did you find a fix?

tarafından

Same problem! I ‘m so over my Acadia and wish I would’ve researched the quality of this model of SUVs before buying mine. Too many issues!!

tarafından

Yorum Ekle

I replaced my sending unit - 3 weeks ago. I drive 150 + miles a day and the light has not come back on. I posted on a forum acadia page, the advice I received was to try the sensor first. The year make and model of mine were notorius to have issues where the sensor stopped sending communicating with the ecm.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

I suggest that you have the dealer or a mechanic reset the memory on you cars computer and update the software. That's all I did and I never the problem again,

tarafından

GregTerry what caused the problem and what were you charged for the reset?

tarafından

Yorum Ekle

Has anyone who had it reset the sensors had this issue again? Because we recently just bought a GMC Acadia SLT 2010 and it shakes when driving and constantly says low oil pressure stop engine it didn't do this obviously while we were test driving it but once we got home we've had nothing but problems

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

We have a 2010 and recently we had to put it in the shop. Low oil pressure alarm was the issue. Spent over $2K, and it did it again.

A timing chain is a likely issue, once the sensors are ruled out; a real headache, but looking back, the Acadia did fair for 10+ years; I am a big GMC fan, but this one Led us to get a Toyota Highlander recently. It has about 175K miles. It’s been in the shop for about 3 months. Goof luck.

tarafından

Yorum Ekle

Yanıtını ekle

Naif sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 13

Son 7 gün: 76

Son 30 gün: 411

Her zaman: 58,669