Ana içeriğe geç

A repair guide for a portable fan with vertically rotating blades that creates an air current for the purpose of cooling or ventilation.

5 Soru Tümünü görüntüle

Remote not Working on Seville Tower Fan

I have a Seville Classic Tower fan and the remote is not working although I put in (2) new batteries. How can I troubleshoot?

Thank you.


Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
1 Yorum

My seville classic tower fan will not receive the signal from a functional remote control. I have unplugged the tower fan and re-plugged. Still won't recognize the remote's signal. Any ideas? thank you


Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm


You can check that the remote control unit is working by using either a mobile phone or a digital camera.

Point the remote at the camera (or phone -using the camera app) and press a button on the remote - any button will do at this stage.

You should see (through the camera LCD display or phone screen) a flashing light at the end of the remote control unit when the button is pressed.

You can check that you are doing it correctly by trying the test using a known working remote control unit e.g. like a TV remote.

If you a using the main ON/OFF button on the remote and you see nothing, try another button and see if that works. (The main ON/OFF button usually wears out first because it gets the most use).

1. If there is no flashing light seen at all, regardless of which button you press, check the following:

a.) That the batteries have been installed correctly

b.) That the battery terminals in the remote are bright and shiny and that they hold the batteries in snugly.

2.) If other buttons work but the main ON/OFF button doesn't, then you can try cleaning the button contact to see if this resolves your problem. Here is a link that shows what to do. It is for a TV remote but the principle is the same.

If you still can't see anything in the camera display then the remote is faulty and would need to be inspected by a competent repairer, although it would possibly be cheaper to source a new remote.

Hopefully this is of some help.

Bu yanıt yardımcı oldu mu?

Puan 5
Yorum Ekle

If the remote control works from the “camera test” described above, you may need to simply unplug the heater and plug it back in again for the remote’s signal to be accepted by the heater. That was the problem with my heater, the remote worked tested ok, but until I unplugged and replugged in the heater, the heater did not respond to the remote.

Bu yanıt yardımcı oldu mu?

Puan 1

1 Yorum:

What if it still doesn't work after unplugging & plugging it back in? I'm troubleshooting a tower fan. It's not the heater but it should be the same in theory.


Yorum Ekle

Yanıtını ekle

Lise Grenier sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 6

Son 7 gün: 53

Son 30 gün: 194

Her zaman: 17,057