Ana içeriğe geç

The April 2014 update of Apple's 13" MacBook Air features refreshed dual-core i5 and i7 processors, plus slightly increased battery performance.

200 Soru Tümünü görüntüle

Shuts down when disconnected from AC

Hi everyone.

This is a follow-up to my MacBook Air 13” (2014) – Water Damage, will not power on. Thanks to everyone who replied and helped out. I finally got the MBA to boot and just about everything works (keyboard, camera, etc), except for the capability of automatically switching from AC power to battery power.

I have installed a brand new NewerTech battery (the old one wouldn't hold a charge), it t was fully charged by the MBA and recognized by coconutBattery. However, whenever I disconnect the MagSafe, it immediately shutsdown. I tried a NVRAM reset, and SMC reset and a SMC Bypass but nothing seems to solve the problem.

I suspect something on the board given that it was water damaged but I am hoping for a little guidance. I checked the PBus Supply & Battery Charger circuitry (U7100) but haven't found anything obvious yet.

Hopefully someone has some ideas.

@mayer @oldturkey03 @danj @reecee @rany

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

Dizüstü Bilgisayar Bataryaları

An easy fix for a big power boost.

Hemen Alışveriş Yapın

Dizüstü Bilgisayar Bataryaları

An easy fix for a big power boost.

Hemen Alışveriş Yapın

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

If it is not showing an X in the battery status (indicating a data line issue), the power is not making it from the battery to where it needs to be.

Check R7006 hasn't blown (common) and D7005. Make sure Q7155 is opening; you can use pages 48 and 50 of the schematic to follow PPVBAT_G3H_CONN and see if this is not making it to PPBUS_G3H

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

You, sir, are amazing!

I had already checked that part of the circuit originally when it wouldn't boot at all and everything seemed okay. However, I just tested R7006 and it was measuring 8.5 Ohms instead of 4.7 Ohms, enough to not be biasing the diode.

I will do a final assembly and test but I think I have a fully functional MBA! Thanks for your help.

tarafından

@refectio no problem, glad I could help :)

tarafından

How do I locate R7006? I have the same problem.

tarafından

Grab a board view file for your board number, and a program (openboardview) to open this. Search "R7006". Use the schematic files to find the value of this, all these files can be found using Google

tarafından

Yorum Ekle

I am not 100% sure but it must be circuit board component issues.

Check every IC resistor etc. Belonging to charging and switching circuit on motherboard.

& Give detail important to capacitors. They gets short at easy in water damage.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Thanks, I'll take a look.

tarafından

Yorum Ekle

Yanıtını ekle

Minho sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 Gün: 1

Son 30 Gün: 5

Her zaman: 260