Ana içeriğe geç

Cellular version of Apple's 2nd generation iPad Air. Model A1567.

87 Soru Tümünü görüntüle

iPad Air 2 charging problems

My Ipad Air 2 (64gb, wifi & cellular, iOS 10.2.1) won’t charge when connected to a wall adapter (original Apple charger, cable and adapter too, my iphone charging and syncing perfectly with these) or sync with my MacBook Pro.

When the battery is fully drained charging start to 2% when it boots the OS and then stops the charging.

I tried to force restart (home and sleep/wake button), nothing changed but when I didn't release the buttons after the first restart, the screen turned on with the sign "connect to iTunes”, a few minutes later the iPad restarted automatically and it was at a higher battery percentage than before, so I think when the last screen was active, it was charging at the background. So I did this process again and again, and the battery percentage was higher at every restart. Once when I did this restart method I left the iPad to charge with the “connect to iTunes” screen and after the next restart the charging didn’t stop till the battery percentage was 98%.

Another surprise when I connected the iPad to my MacBook Pro when it was fully drained, the charging was started and at 2% the OS booted on the iPad and iTunes started to syncing my device. I made a backup save and then upgraded to iOS 11.2.6. checked the battery with Coconut Battery(145 loadcycles, 6975 mAh capacity, 95% health, good condition).

Nothing changed after that. The device won’t charge and sync when the iOS is running but if I restart when plugged in to my MacBook Pro it is syncing and charging, till 95% the charging icon is active next to the battery sign, after that the charging icon fades away (checked on iTunes too) but the charging doesn’t stop.

Any good ideas? I don’t know how can I solve this problem. I called the local Apple Authorized Service Provider (Budapest, Hungary) they said that "This is a fault of the logic board can’t repair only change the full part"...

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

There's definitely a problem with the charging circuit on the logic board. Most charging problems are Tristar related but on the iPad Airs, they can be more complicated and involve the PMIC, which is a very expensive component.

You will need to find a repair shop that does micro-soldering repairs and discuss how much they would charge for this type of repair.

Bu yanıt yardımcı oldu mu?

Puan 2

2 Yorum:

How much is a PMIC?


At least in my situation it was not the TriStar


Yorum Ekle

I have probably the same issue on my iPad Air 2, 64GB WiFi, iOS 12.3.

It started when the charging cable was shorted a couple of weeks ago.

I have a USB power meter so I could verify that the cable was shorted and I can also see when the iPad is draining power from the charger or not.

When it stops charging, it remains like that until the next reboot so the software is disabling the lightning port completely until then if it detects an error.

If I power it off and have it plugged in when it stops charging, it reboots automatically as it would if I would plug the charging cable while it was powered off.

However, in that case it will stop charging again before it completes booting up.

To charge it again I’m doing the following steps:

  • I unplug the cable from both the iPad and the charger
  • I power on the iPad and wait for the pin screen
  • I plug the cable first on the charger and then on the iPad
  • At that time, the charging icon becomes green and the battery charges.
  • After I give the pin, it will either continue charging silently (the icon doesn’t show that it’s charging but I can see it in the USB power meter) or it will stop draining any power so I’ll have to repeat the process which is obviously really annoying.

Sometimes I get the error “This accessory may not be supported” but most of the times it stops displaying the charging icon silently.

Once it drained all the battery and it got stuck in a loop of booting, displaying the pin screen for a couple of seconds with battery at 2% and then rebooting over and over again.

To exit from that situation, I managed to get it in DFU mode and I left it there for a few hours to charge to 100% while it was in the black screen using the Macbook USB port. The recovery mode didn’t work when I tried it.

I’m going to replace it soon but at least these workarounds can postpone the need for replacing it at the moment since it’s not completely dead.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Kristóf Krausz sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 3

Son 7 gün: 27

Son 30 gün: 117

Her zaman: 11,054