Ana içeriğe geç

Repair guides and support for cars manufactured by the German motor group, BMW. iFixit is not affiliated with BMW, and BMW has not created, endorsed, or sponsored the content below.

212 Soru Tümünü görüntüle

Temperature gauge not working

After removing the instrument cluster to replace bulbs, upon reinstallation the temperature gauge failed to work. I replaced the temperature sensor as it was very inexpensive first. Grounding its terminal produces no movement at the gauge. I swapped in a ‘new’ used gauge and still nothing. When I turn the key to the on position, the gauge moves a hair only, though not always, but intermittently. The printed circuit board looks perfect without any signs of corrosion or damage and all other components in the instrument cluster (fuel gauge, lights etc are working fine. What do I do? Thank you very much!

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
5 Yorum

Hi @scottjeffrey ,

You may have to use an Ohmmeter and do point to point testing on the pcb back from the two gauge connections (input side to meter and either power or earth feed to the meter - don't know what your car uses) until you find the open circuit in the path. Try not to press too hard with the meter test probes on to the solder joints along the path etc as if it is a dry joint it may make for a good connection due to the pressure applied by the probe.

It would be handy if you knew which harness connector pin the temp gauge feed came into the cluster assembly on, that way it may make it easier to trace, from input to gauge, assuming the other side of the meter would have either Earth or Battery connected, commoned from the other gauges connected to the pcb

tarafından

Hi Jayeff, Let me thank you for your time and effort. I reinstalled the cluster earlier and while all the connections were engaged and still no movement of the temperature gauge, I put my hand behind it applying a little back and forth or jiggling motion and the temp gauge came to life. Instead of leaving it alone, lol, the thought occurred to me that perhaps the reading can't be trusted if there is improper resistance to to a problematic connection. I also don't know if it cam e on due to something making contact (and then losing it again inside the cluster involving the PC board. Used some de exit on all external connections but again nothing from the gauge even when I tried jiggling at the connections. Any wisdom on the situation and how I might proceed? Thanks again--Scott

tarafından

Hi @scottjeffrey ,

I would look at the harness connectors to check if they are OK in that depending on the type are they exerting enough tension on the pcb connector socket pins or however it plugs in.

Try holding the plug housing and the cluster housing firmly and just move the wires in the harness to check if this alters anything

tarafından

Follow up. Because it was working for a short time this morning after wiggling the pig tail wires I assumed I had continuity from the sensor. I ran an additional wire from the sensor to the pigtail, pushing it into the hole along with the original wire which is for the temperature gauge and viola! Temperature gauge working. I am assuming therefore that the problem is in the wire/connector inside the pigtail. I don't know how to remove the wire/connector assembly from the pigtail itself to see whats going on there. I removed the second wire I had inserted and it is still working. For now. Also have a concern with my limited understanding of electrical theory (my father an electronic engineer used to say, "Scott, a little knowledge is a dangerous thing", lol). Any way my concern regards extra resistance due to the problem I am assuming is in the pigtail causing a false reading although the reading I am currently getting is consistent with my measurements at the water distribution fitting.

tarafından

Hi Jayeff, That is how I initially got it to work early today. But after disconnecting and reconnecting the harness connector to the board(round, 12 pin), I couldn't get it to work again until the above described attempt. I had cleaned the pins and the plug as well but nothing until I ran the second wire from sensor into the plug in the correct place. And its working now without the second wire so somehow it established contact which had been interrupted by something? Corrosion, looseness. I wish I knew. Hate to not be sure its fixed right. Hey, thanks again. Much appreciated-Scott

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hi @scottjeffrey ,

You are fortunate that you know which connector pin it is.

Hopefully there is enough slack in the harness to be able get to it to fix it.

Usually the wires in the connector plug (socket?) are crimped to the connector pin, either male or female (don't know what you have)

They don't strip the wire but the connector pin has "teeth" which cut through the insulation to get to the wire when it is being crimped into the pin.

If you are lucky,to get the pin out of the plug (socket?) holder, on the top of the plug (or the bottom- if it is a double row) for each pin you might see just a bit of metal in the plastic in line with each pin. This is the "barb' on the pin which prevents the pin moving back in the wire direction when the plug is inserted into the socket, or to allow you to remove the pin easily by just pulling on the wire

If you push down on this bit of metal with a pin, nail etc whilst simultaneously (gently) pulling the wire back out of the plug the whole connector pin should come out so that you can either re crimp the wire or remove it, strip it and solder it to the pin.

You then just have to reinsert the pin from the wire end until the barb click into its slot (check in the pin's plug hole for where the "barb" projection is so that you line the barb up with the barb holder (for want of a better term) or make sure that it is on top (bottom) so that you'll see it in the slot where you used the pin to extract it,

If you can't see the barb because it is a solid plug, you could try using a pin from the open end (not the wire end) and push it down between the connector pin and the plastic hole which it is in and try to push the barb down, whilst gently pulling the wire back out at the same time.

Don't pull too hard because you might pull the wire out (if it is a loose crimp) and leave the connector pin in ;-(

Another option is if the pin on the harness connector is a split male or split female pin (either one) i.e. it is actually two segments and not a single piece of metal you may be able to use a small screwdriver etc too slightly widen the pin (open the split ) if it is a male pin or to close the split a bit more (if it is a female pin) so that more tension is placed on the pin in the connecting socket on the pcb ensuring a better connection

Hopefully this makes a bit of sense ;-)

Bu yanıt yardımcı oldu mu?

Puan 3

3 Yorum:

Jayeff it makes a lot of sense. I can't thank you enough! Have a great day--Scott

tarafından

Hi Jayeff, I am copying a message I sent to some old BMW friends.

Thanks much—Scott.

Before removing my instrument cluster a few months ago my temperature gauge worked fine. While out I overhauled the cooling system and charging system along with installing an updated a/c compressor and some little things. I have everything back together, the car runs beautiful. When I reinstalled the instrument cluster a few days ago I had no temp gauge. I even swapped another in. I also put in a new sensor. Yesterday morning I fiddled with the pigtail wires while hooked up to the printed circuit board and low and behold on came the temp gauge later to fail again. I wasn't getting a reading indicating continuity between the plug (pin 11) and the other end of the brown and white striped wire at the temp sensor. I ran a second wire attaching to the temp sensor end (with the original brown and white wire still connected and pushed it in the plug at pin 11 sandwiched in with the factory brown and white wire while the pigtail was still connected to the cluster board and poof, temp gauge working. I then pulled the second wire out of the pigtail and still had a working temp gauge. This is what has me perplexed. How could it have continued to work yesterday without the second wire??? This morning I started the car and no temp gauge. I pulled the wire from the pigtail and the connector is nice and shiny and looks fine but still no continuity to the other end at the sensor. I know or imagine I can just run a new wire and find the correct connector pin end so that it can be installed into the pigtail and mate with the male pin on the cluster's back. But I would rather fix the original. It isn't making sense to me. How could there be intermittent albeit brief continuity, and how did some break in the wire (in a section where the wire is hidden from view) occur in the first place? Any thoughts about any of what I describe based on your experience and knowledge. Your input would be much appreciated as always. Happy Sunday--Scott

tarafından

Much appreciate you sharing your knowledge!

tarafından

Yorum Ekle

Yanıtını ekle

scott sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 3

Son 7 gün: 20

Son 30 gün: 129

Her zaman: 12,617