Ana içeriğe geç

9th generation of Chevrolet's full sized SUV, based on the GM GT800 platform.

22 Soru Tümünü görüntüle

Engine bogs down and stutters under hard acceleration

I have a 1994 chevy suburban (didnt give that year option when choosing for post) with the 5.7L gas engine. She idles fine, revs fine in park, but when I go to drive, if I accelerate hard she bogs n stutters. If I'm in 4th gear and try to accelerate, same thing. I can only accelerate very slowly once in fourth gear. Engine bogs down, trans doesn't seem to even try to downshift to help accelerate. Trans was rebuilt a couple years ago, and I'm trying to figure out what is broken so I can fix it! Distributor is less than one year old. Am going to replace fuel filter. Don't think that's the problem but I'm doing it anyways. My father checked it out and said it smells like its running rich. Could this be causing this? Should I replace o2 sensors?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hi @brandon_k

Have you tried checking the OBD codes, just in case they might show something, you never mentioned it?

Don’t know the vehicle but online seems to show that the port is located under the dash to the left of the steering column

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

I haven't, yet. No check engine light or anything. Might jump the port tomorrow (have read multiple places saying this will show me on the dash via a series of flashes).

tarafından

No codes. Did some local driving today. Engine seems to run fine. It seems more like an issue with the transmission not downshifting when it should...

tarafından

@brandon_k

Maybe check the easy things first. Apologies if you've already done so.

Have you checked the transmission fluid and filter to see that it is correct level, clean and doesn't smell burnt etc? Online it seems that changing the fluid seems to vary between 30,000 and 60,000 miles, for your year model, depending on how the vehicle is used

tarafından

will have to check tomorrow or the day after. Was fairly late when I got home and drove it.

tarafından

Truck shows no codes. Haven't checked/changed filter. Trans pan has rear edge on crossmember so can't get to the bolts. Fluid seems fine though.

tarafından

3 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

brandon k sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 3

Son 30 gün: 4

Her zaman: 136