Ana içeriğe geç

2.5 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.1 GHz) with 3 MB shared L3 cache.

266 Soru Tümünü görüntüle

MBP Not Detecting Battery

After replacing the faulty speakers of my MBP in-line with the iFixit guide, the device stopped detecting the battery. At login, the battery icon shows 0% for a couple of seconds, then shows an “X” icon. Also, System Report does not identify the battery.

I have tried removing and re-connecting the battery, and both SMC and NVRAM.PRAM were reset, but to no avail. The laptop works fine with the power cord, sometimes slightly laggy.

All was working fine prior to the speakers replacement.

Any help would be greatly appreciated. Thank you.

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
4 Yorum

Given the age of your system I think it just was its time.

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question

That should nail things down.

tarafından

After answering about what @danj is asking bout - Did you happen to use a plastic tool to lift up on the battery or something metal? I ask because we see this happen quite often if a few of the battery pins are shorted out.

tarafından

@danj For some odd reason, CoconutBattery quits unexpectedly.

tarafından

@joesipaq I did use an iFixit plastic tool to lift all connections during the whole process.

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

I fear the battery cable got damaged during your repair as CoconutBattery will react this way when it polls SMC and can’t get any data. Remember your SMC data was lost when you disconnected the battery for a length of time.

Time for a fresh battery MacBook Pro 13" Retina (Late 2012-Early 2013) Battery and here’s the guide MacBook Pro 13" Retina Display Late 2012 Battery Replacement

MacBook Pro 13" Retina (Late 2012-Early 2013) Battery Görseli

Ürün

MacBook Pro 13" Retina (Late 2012-Early 2013) Battery

$99.99

Bu yanıt yardımcı oldu mu?

Puan 1

3 Yorum:

After looking at other threads with similar problems, I tried pulling out the power cord when powering on the device, once hearing the boot up chime and the MBP remained ON until I entered the passcode.

Could this mean that something else is faulty other than the battery connector?

tarafından

@bugie - Is CoconutBattery now working? If not it doesn't change then its still the battery.

tarafından

Unfortunately, CoconutBattery is not working, even after a fresh OS install. Will consider replacing the battery than. Thanks a million!

tarafından

Yorum Ekle

Yanıtını ekle

julianbugejacoster sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 11

Her zaman: 92