Ana içeriğe geç

Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

555 Soru Tümünü görüntüle

Panic after changing battery

Got a battery kit for iFixIt, and it seemed everything worked just fine, no problem during the swap.

But when booting, now macOS panics after a while, and the Windows partition that was there too boots fine but with quite a few video artifacts. It makes me think macOS panis when switching to the graphics card but not really sure.

I had a USB key with VMware ESXi on it and that one boots just fine, I don’t think it’s using the graphics drivers at all.

Booting lid closed on an external monitor has the same symptoms.

Any ideas ?

[EDIT] Tried resetting NVRAM and SMC without success

Update (09/02/2021)

Here is a snap of the last line before crash

Block Image

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

What do you see in the crash log?

Also did you try running diagnostics?

tarafından

Updated question. Thanks !

tarafından

Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Have you tried resetting the NVRAM / PRAM? This could solve the issue, but be aware that it also resets some minor preferences (see last bullets in the link).
If you suspect the graphics card to be the culprit, do you have a dedicated graphics card and are you running some kind of CUDA drivers? They might get reset as well so make sure you are using the most recent drivers depending on your OS. BTW, which MacOS version are you running?

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Thanks Tobias. Yes, NVRAM and SMC have been reset. That's a vanilla install of macOS 10, the latest supported by this machine (10.15).

The recovery boot also seems to stall but not always panics.

tarafından

Yorum Ekle

It appears the NTFS volume has a corruption! You’ll need to boot up under macOS and make sure the GUID volumes are in good order using Disk Utility. Then reboot under Windows and use Disk Management to repair the NTFS volume.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Thanks, that's probably not related though. By then WindowServer should have started and graphical UI be up. NTFS issue is probably normal as the Windows boot we tested was shut down abruptly.

Thanks

tarafından

Yorum Ekle

Yanıtını ekle

yann sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 2

Son 30 gün: 2

Her zaman: 48