Ana içeriğe geç

2.0GHz, 2.3GHz, or 2.6GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache.

580 Soru Tümünü görüntüle

MacBook needing reset after sleeping

Hi everyone,

So a few months ago my computer suddenly died. I brought it to a repair shop where I was told the hard drive had finally broken down after so many years. I got a replacement hard drive and the computer has been working well, except for the following issue:

Whenever I closed the lid to put the MacBook to sleep for longer than a few hours, when I opened the lid again, the screen would remain black and I would have to hold the power button to reset the computer. This is annoying because I have to re-open all the programs, windows, etc. that were open when I put the computer to sleep. This was happening whether plugged in to an adapter or not.

I spoke with the repair guy and we tried switching "Enable Power Nap" on in the Energy Saver System Preferences for both Power Adapter and Battery. Now if I close the lid overnight while the computer is plugged in, I'm able to open it and log in without doing a system reset. But sometimes I hear the fans working hard and in the morning the laptop is quite hot so I wonder if there is a better option for the longevity of the computer than using Power Nap.

But the real issue is when the computer is operating with battery power. Even with Power Nap enabled, if I close the lid and the computer is asleep for more than an hour or so, when I open the lid the screen will be black and will not turn on without holding down the power key to do a reset (even though it seems like the computer is on with a black screen before I do the reset because it is hot and the fan is running). When I hold the power button for a few seconds to reset, the computer makes the mac awakening noise once, screen remains black, then a few seconds later makes the awakening noise again, and a few seconds later I get the apple logo with the loading bar.

I have already tried resetting the SMC using the instructions here:

https://support.apple.com/en-us/HT201295

My MacBook is currently running on High Sierra Version 10.13.6.

Block Image

Thank you!!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1

4 Yorum:

What is happening is the SMC services are going into a latched state as it encountered an issue. So now you'll need to see if you are getting an error running the onboard diagnostics! Restart your system and press the D key to enter. Let us know what the error code you got.

Given the systems age you maybe due for a new battery. Install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question so we can check it out as well.

tarafından

Hi Dan,

Thanks for your input. I was having battery issues previously and got a replacement about 1-1.5 years ago so I am hoping my battery is in decent shape. I have attached the Coconut screenshot.

I'm happy to try the restart but I'm not sure I understand the instructions. So should I turn the computer off, then hold down the D key, then as I continue to hold D, push the power button to restart the computer?

When exactly should I hold D?

Thanks again!

tarafından

@share5 - Shutdown the system, restart and once you see its starting press the D key to enter.

Reference: Mac startup key combinations

tarafından

Ok I was able to run the diagnostics! It came back with a checkmark saying "No issues found".

Any ideas about what to try next?

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:

OK, lets see if the drive is your issue, restart your system again and this time we want to get to the the macOS Recovery. From the menu select Disk Utility here we want to run Disk First Aid to check your internal drive. Did it faint any errors?

Update (08/23/2022)

@share5 - Well this is stating to sound like the Hall sensor is messed up which is on the back side of you logic board

Block Image

You'll need to scare up a junk to get one.

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Hi Dan,

Thanks again for your help with this. I tried restarting in MacOS Recovery mode and ran First Aid - no issues were identified.

Is there anything you think I should try next?

tarafından

Yorum Ekle

Yanıtını ekle

MJM sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 4

Son 7 gün: 13

Son 30 gün: 31

Her zaman: 451