Ana içeriğe geç

2.0GHz, 2.3GHz, or 2.6GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache.

580 Soru Tümünü görüntüle

No charge, no light on charger, tested two chargers and replaced DC-in

Hello,

a few days ago my Mac started to randomly stop charging depending on how the cable was positioned. The charger was beat up pretty bad so I ordered the same charger (used official Apple charger) off Ebay. This second charger never worked, while the old one was still charging sometimes. Since then both chargers have stopped working.

After all this I ordered a replacement DC-in board since the contacts on the original one looked burnt. Still no charge, no light. Also tried measuring voltage and amps while the PC was open on the DC-in board but my multimeter showed no readings.

This is the DC-in board I bought

I'm currently talking with the Ebay seller to get a replacement charger but at the moment I'm not very optimistic... could the middle data rail be damaged on the mainboard, meaning no communication between charger and laptop = no charge? Or possibly a power rail? How would I go about diagnosing this? Seeing as no power enters the machine I hope both chargers were done for and the replacement works, otherwise this repair is out of my league.

Old charger:

Block Image

Update 2023/08/13:

Managed to get the old charger to connect again and it showed a green light. After a while (10-15min) the mac still didn't want to start, just showing an empty red battery but indicating that it was charging.

Now I decided to reset the SMC, since that was always suggestion number one to fix macs charging weirdly. Now the indicator on the charger is glowing amber, but pressing the power button does nothing. Charging brick is also not heating up at all. After about 20-30 minutes I disconnected the charger and now both chargers don't work again...

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

There is a better way here, your system will run without the battery connected.

Let’s do this, disconnect the battery following this guide to Step 4 MacBook Pro 15" Retina Display Late 2013 Battery Replacement. Now press and hold the power button for a good 15secs to fully discharge the logic board. Now plug in the MagSafe charger, does the cord LED light up? What color Amber or Green now. Did the system spontaneously start up?

Bu yanıt yardımcı oldu mu?

Puan 1

3 Yorum:

Sadly I'm on break from work so no tools til next monday but I'll definetly try this. Also, earlier I managed to get the laptop to charge with the old charger and new DC-in board: the charger was lighting up green and the mac started charging (but not turning on, since it was completely empty). As soon as I moved the plug on the machine it stopped again. I'll attach a close up of the original charger in the post so you can see how damaged it is.

tarafından

@claymore10487 - The cords pogo pin is burn’t! This is not good this is a sign of a failed MOSFET switch logic on the mother board.

tarafından

@danj Alright. Once I can open up the machine again I'll check the board for damage. Thank you

tarafından

Yorum Ekle

Dear Claymore,

It seems that the issue may be with the motherboard. Please check if there is any damage or fault in the charging input line to the last line . You can test the current using a multimeter. If there is no current or if there is a burned chip, please refer to the manual on the Apple website for instructions the chip name model . Once replaced, please try again.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

claymore sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 1

Her zaman: 51