Ana içeriğe geç

The HP Mini 110 is a netbook computer made by Hewlett-Packard, originally released in October 2009.

7 Soru Tümünü görüntüle

AC Socket is loose and wont charge. How do I replace?

The AC socket on my HP Mini 110 is no longer holding on to my AC plug. It needs to be replaced. Can someone tell me what I need to purchase? I am being told that ac socket is sodered onto the motherboard/mainboard and the entire piece will need to be replaced. Can someone confirm this and any instructions and recommendations on where to buy a new one?


Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm


The DC socket that accepts your AC to DC adapter cord plug is part of a module known as the Power/ Battery Pass Through Board.

Here is a link to the service manual for your model netbook. Scroll to p.66-67 to see how to remove the board.

The board is connected to the motherboard via a cable connection.

The part number for the board is 537615-001. If you "Google' just this number you will get suppliers for the board. Here is just one so you can get an idea of what it looks like and what it may cost. There are others which may suit you better.

Bu yanıt yardımcı oldu mu?

Puan 2

2 Yorum:

Thank you so much for replying. This has been driving me crazy for many months and all the little tweaking I did to try and keep the charge going has finally just stopped. So I am forced to fix this problem if I ever want to use my cute little Tord HP Mini 100 again. I did go on the HP Chat and talk with them and they told me to order the 581326-001. My model the HP110_1136NR PN# VM134UA. I hope they did not instruct me to order the incorrect part!. I do see on the guide you linked over to me that this part number they instructed me to buy is indeed under the Power Board section . On page 21 it gives the PN you suggest and the HP rep PN they suggest. I think mine falls under the second group for 581326-001. What are your thoughts?

Power/battery pass-through board

For use on the following model numbers only: HP: 110-1000 — 110-1099 and Compaq:110c-1000 — 110-1099 537615-001

For use on the following model numbers only: HP: 110-1100 — 110-1199 and Compaq: 110c-1100 — 110-1199 581326-001


Hi @spanishwoman69 ,

I agree, the part number is 581326-001, as it is the part number for HP Mini 110 models between 1100 1199.

My initial answer was based on the information in the question you asked. The description of the netbook model shown at the top of this page alongside your question, is HP Mini 110 -1046NR and in your question, you only state that it is a HP Mini 110. As you wrote the question, I reasonably assumed that this was the model number of your netbook, given that there was no other relevant model information available to me. Therefore I recommended the part number for that model which is obviously different and as it turns out incorrect for your 'actual' netbook.

Don't know where you were told to order the part from but if you enter just the part number, nothing else, into the search box of your browser, you will get results for suppliers for you to choose from.


Yorum Ekle

Hi Jayeff,

I changed out my power-board and it was much easier than I thought. But...when I went to plug it in, I got no power at all. I went in a second time to make sure that I did it correctly and everything looked perfect. Somone on this site suggested that perhaps I did not connect the keyboard back on correctly. The connector was actually a ribbon that slide into a snap connection. you just slide it under and snap it down. Weird. The power board had an actually connector that you snap in and pull out, so that one was secure. Is it possible that this is what the problem is? Someone else also suggested a hard reset, which I had never heard of. Something about pulling battery out and holding power button in. I have not tried this yet. I am pretty confident that the problem was the power board because my AC adapter would not hold in the socket. Sometimes I could get it to charge if it was situated just right but this was annoying. If you bumped it in the slightest way, it would stop charging. Otherwise, when I had a charge, the computer worked great. Any ideas? Should I take it apart a third time and make sure I did not hook the keyboard up incorrectly? Its a blue plastic ribbon that kinda fell out when I open the keyboard. At first I thought i pulled it out when I lifted the keyboard, but it simply slide out from the snap it was pinned under. Does that make sense?

Let me know if you have any suggestions. Thank you.

Bu yanıt yardımcı oldu mu?

Puan 0

3 Yorum:

Hi, When you plug in the AC/DC power adapter cord into the netbook and switch on the wall outlet is there an AC adapter light glowing on the left side of the netbook?

If not you may have to check the Power Pass through board cable connections again

If so is the battery light on the front of the netbook giving any indication that the battery is charging?

You could try a reset - it won't do any harm. Unplug the AC/DC power adapter cord from the netbook, remove the battery, slide the netbook power swicth to the ON position and leave it there for a minute. Then slide the netbook power switch to the OFF position, re insert the battery, reconnect the AC/DC power adapter cable, switch on the wall outlet. See if your netbook will switch on.

Also see if the netbook will start with the battery removed and the AC/DC adapter cable connected and on

2 part answer.


With regards to the keyboard cable, I haven't much experience with laptops but on desktops a 'missing' keyboard does not prevent the PC from powering up. It does stop the PC from booting into Windows but there is a message on the screen to say Keyboard error. So I'm thinking that we won't know about your keyboard until we can get the netbook to at least turn on.


Thank you so much for your guidance. I see no lights at all anywhere on the side or front. I will try the hard reset again. You have to hold the slider over and its possible I did not hold it long enough, as you have to kinda hold it in between your fingertip and nail. Uncomfortable to say the least. If that does not work, I will open it back up tomorrow and make sure I did not miss anything. Perhaps I got a bad power board. I will keep you posted.


Yorum Ekle

Yanıtını ekle

gloriafeil sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 3

Son 30 gün: 5

Her zaman: 1,872